RTF copy/paste for Netbeans 8.0.2 - plugin detail

An extension for Netbeans to copy the editor content into clipboard in the RTF format. This enables you to copy the editor content to OpenOffice or MS Office preserving the syntax coloring.

NetBeans Plugin - RTF copy/paste for Netbeans 8.0.2
Plugin owner: misias
Website: http://code.google.com/p/rtfcopypaste/
Added: 2015-01-01
License: GPL v3
Category: Editing
Downloaded: 3,998 times
Rating:
 4.52, by 2 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.02 MB   Last Update: 2015-01-06

What's new in this version

Compatibility with Netbeans 8.0.2.

Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Module to copy/paste Netbeans editor content with formatting to RTF format.

Usage:

  • 1. Select code,
  • 2. Click right mouse button to expand popup menu,
  • 3. Select "Copy as RTF" option to copy, selected content to the system clipboard,
  • 4. Paste clipboard content to your RTF editor like OpenOffice or MS Word (special paste).

Additional options:

  • 1. Go to Tools - Options
  • 2. Select Copy/Paste tab to customize plugin options.

Compatibility:

I've tested this plugin on Netbeans 8.0.2 with OpenOffice 4.1 and MS Word.

Developing:

If you want to further develop this plugin - just write to me, I will add you to the project owners.

Suggestions:

If you have some suggestions: mw219725@gmail.com

[ You have to be logged in to be able to comment. ]

User Comments

  

Almost Good; So Close

This is a great plugin but I am unable to copy the background color of my IDE when I choose this. However, I don't seem to find any threads or posts addressing this issue on the web. Am I the only one facing this?(I use the Darcula plugin, is that an issue?) I've tried repeated installs and it still wont work for 8.0.2 . Everything else is fine. I wish the option to put RGB or Hex for background is available in the Copy/Paste options. Waiting eagerly for a fix while I still manually RGB 18,30,49 Best Regards from the other side of the globe.
Posted by n00ntel on Mar 23, 2017
  

New version for NB 8.1

Thanks for reporting. I will ticket it and fix.
Posted by misias on Nov 17, 2015
  

New version for NB 8.1

Thanks. It works ! But I don't see the CopyToRTF with the right click, only in menu "edit" and I must use the second converter in the parameters of the plugin.

[edited]
After some work, strangely, it works now with right-click (not for HTML code)

[edited]
Now it works no more. It seems that the plugin is instable. I believe that is rather a bug on a part of Netbeans 8.1 with copy/paste operation outside (MacOS 10.11.1). See last post of https://netbeans.org/bugzilla/show_bug.cgi?id=255650
Posted by jcstritt on Nov 17, 2015
  

New version

Just released version compatible under 8.1: http://plugins.netbeans.org/plugin/61409

Also, abdul202, thanks for the idea. I have ticketed it for future development.
Posted by misias on Nov 16, 2015
  

Version not compatible with NetBeans 8.1 !

Can the creator of this plugin adapt the plugin to release 8.1 of NetBeans ? Thanks
Posted by jcstritt on Nov 14, 2015
  

new option

it's really amazing i wish you add a surrounding gray box around the code snippet as an option
it will help me a lot i use it to paste code to evernote
Thanks
Posted by abdul202 on Nov 12, 2015
  

Its really very good.

I will just say...

Thank You...
Posted by Amit_Gorvadiya on Jun 30, 2015
  

Working?

Can anyone else confirm if it works under 8.0.2?
Posted by misias on May 20, 2015
  

Works in 8.0.2

Works for me in 8.0.2
Thanks!
Posted by desmond_kirrane on May 20, 2015
  

Same error. Please test plugin

"Some plugins require plugin Editor Settings Storage to be installed.
The plugin Editor Settings Storage is requested in implementation version 201411181905. The following plugin is affected:"
Posted by Ageinfo on Mar 05, 2015
  

Not working

I am using NetBeans 8.0.2. This plugin doesn't work in that.

The next button is disabled. The message shows

"Some plugins require plugin Editor Settings Storage to be installed.
The plugin Editor Settings Storage is requested in implementation version 201411181905. The following plugin is affected:"
Posted by neetesh_dad14 on Jan 28, 2015
  

Same results

I deleted the previous download, downloaded the replacement .nbm - I'm still getting the exact same results.

I then tried deleting cache - same results.

"Some plugins require plugin Editor Settings Storage to be installed.
The plugin Editor Settings Storage is requested in implementation version 201411181905. The following plugin is affected:       RTF copy/paste
Some plugins require plugin Editor Tools Storage to be installed.
The plugin Editor Tools Storage is requested in implementation version 201411181905. The following plugin is affected:       RTF copy/paste"

----------

Follow-up 1/14. <\b>

My NetBeans installation was originally 8.0, which was updated/rebranded to 8.0.1 and then 8.0.2 as updates were posted. I created a new NetBeans 8.0.2 installation (via the "all" .zip package) - this plugin installs correctly without any warnings or comments. I also created a new NetBeans 8.0 installation (via the "all" .zip package) - upon installation of the rtfcopypaste plugin I receive the message

The following plugins will also be installed because one or more of the plugins you are about to install depend on them:
Actions APIs [6.35.1]
Editor Settings Storage [1.45.1]
Editor Tools Storage [1.4.1]
JUnit 4 [1.14]

In my current 8.0.2, the listed plugins are present, with exactly the same version numbers.

Any idea how to proceed? I'm very reluctant to delete my user directory as my current 8.0.2 install is quite heavily customized (120 plugins, a LOT of options set) and I've experienced problems in the past using import/export settings.....
Posted by joecsc on Jan 06, 2015
  

Binaries replaced

please test again.
Posted by misias on Jan 06, 2015
  

Won't install

I downloaded and attempted to install - getting "some plugins require plugin Editor Settings Storage and Editor Tools Storage to be installed" - both messages reference implementation version 201411181905.

NetBeans info:
Product Version: NetBeans IDE 8.0.2 (Build 201411181905)
Java: 1.8.0_20; Java HotSpot(TM) 64-Bit Server VM 25.20-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_20-b26
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
User directory: C:\Software\NB8.0PersonalUse\NB8.0\NBUserSettings\8.0
Cache directory: C:\Software\NB8.0PersonalUse\NB8.0\NBUserSettings\8.0\var\cache

Thanks in advance!
Posted by joecsc on Jan 05, 2015
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo