CppGnuAutoTools - plugin detail

Gnu AutoTools Extension Allows running libtoolize, aclocal, autoheader, automake, autoconf, and configure from a menu, dialog driven system. You can add this plugin to the C/C++ plugin. Can also be used to create a deploy-able project from scratch using the New Project interface as you would with a C++ or C project. After a project has a Makefile, you can then import the project into C or C++. Works on both 32bit and 64bit versions of Ubuntu 14.04 and rewritten to work on Netbeans 8.0 Provides menu options for Run->Autotools: Libtoolize ACLocal AutoHeader AutoMake AutoConf Configure Clean Autotools files from Project.

NetBeans Plugin - CppGnuAutoTools
Plugin owner: derbster
Website: https://github.com/JohnDRussell/cpp-gnu-autotools-netbeans-plugin/
Added: 2013-11-15
License: GNU GENERAL PUBLIC LICENSE Version 3, 29 June 2007
Category: Building
Downloaded: 1,685 times
Rating:
 0, by 0 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.58 MB   Last Update: 2015-04-28

What's new in this version

Works with Netbeans 8.0 this is Version 1.8.8 This repairs the issue with JUnit and JUnit 4.10 no longer needed.

Verifications for NetBeans versions

Plugin is not subject to any verification

Download plugin   Download size: 0.50 MB   Last Update: 2015-04-19

What's new in this version

This is the Netbeans 7.4 version Repaired 2 issues. Uses safer permissions. Hides permission handling. Added progress bar. See homepage for details.
2 New Project templates located in the C/C++ section. [Generic C Autotools Project] [Generic C++ Autotools Project]
Each of these projects creates the following files:
AUTHORS HACKING
BUGS INSTALL
ChangeLog Makefile.am
configure.ac NEWS
COPYING README
depcomp TODO
See the homepage for further details and tutorials

Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

An Extension plugin for C/C++ plugin. This extension plugin adds the Gnu Autotools processing to the C/C++ Run Menu. Designed to work with the CDT plugin. Allows the creation of two different Autotools Project under Project New C/C++ Generic C++ Autotools Project. Exclusively for Ubuntu 14.04 and higher 32bit and 64bit.

[ You have to be logged in to be able to comment. ]

User Comments

  

The plugin JUnit 4 is requested in implementation version 201411181905

Hi!
I'm trying to install CppGnuAutoTools - plugin but when a click on "install" button a window is shown with the fallowing message

"The plugin JUnit 4 is requested in implementation version 201411181905"

My NetBeans version is 8.0.2 and according to the plug-in manager Junit is activated

Version: 1.1 Source: Certified Plugins
Plugin Description
Includes the JUnit unit testing library and corresponding library definitions. 3.x and 4.x versions are both included


What is going on ?
Why I can't install CppGnuAutoTools plg-in ?

Thanks in advance

Fabio S.
Posted by FabioStafforte on Apr 25, 2015
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo