PHP WordPress Blog/CMS - plugin detail

Support for WordPress.This plugin provides the following features. New Wordpress Project wizard. Create theme(Underscores) action. Hyperlink navigation and code completion for filter and action function. Shortcut nodes for theme and plugin directory.

NetBeans Plugin - PHP WordPress Blog/CMS
Plugin owner: junichi11
Website: https://github.com/junichi11/netbeans-wordpress-plugin
Added: 2013-01-28
License: CDDL-GPL-2-CP
Category: Web Applications
Downloaded: 13,288 times
Rating:
 4.31, by 7 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.11 MB   Last Update: 2014-03-31

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version



Verifications for NetBeans versions

8.0 verification PASSED See verification details
Download plugin   Download size: 0.10 MB   Last Update: 2014-01-27

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

  • Add custom content name(default is "wp-content") settings to project properties
  • Support for wp-cli
  • Notification for new versions (core, plugin and theme)


Verifications for NetBeans versions

7.4 verification PASSED See verification details
Download plugin   Download size: 0.09 MB   Last Update: 2013-07-23

What's new in this version

works on only 7.3
  • Create New WordPress Project
  • a few Code Completion for add_filter(), remove_filter(), add_action(), remove_action()
  • Template files for plugin
  • themes and plugin nodes
  • create theme(Underscores, Barebones) action
  • create plugin action (this is very simple feature)
  • hyperlink navigation


Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Support for WordPress

Usage

README file on github

old versions / other build version

old / other build versions

Issues

https://github.com/junichi11/netbeans-wordpress-plugin/issue

History

  • 0.1 : basic support
  • 0.2 : create theme(Underscores)
  • 0.3 : hyperlink navigation for a few functions(filter and action)
  • 0.3.1 : improve code completion
  • 0.4 : for NetBeans7.3
  • 0.4.1 : Fix #4
  • 0.4.2 : Sign nbm
  • 0.4.4 : add create barebones theme, add create plugin action(#2)
  • 0.4.5, 0.4.6 : fix #8, #9
  • 0.4.8 : fix a bug
  • 0.5.1 : Changes for NetBeans 7.4
  • 0.6.0 : Support for run command (wp-cli)
  • 0.6.1 : fix a few issues
  • 0.6.2 : fix #20
  • 0.6.4 : #26
  • 0.7.0 : Changes for NetBeans8.0
  • 0.7.1 : 0.7.1

[ You have to be logged in to be able to comment. ]

User Comments

  

RE: NetBeans 8.0 beta

Hi NeilC,

We can not use version 0.6.* to NetBeans 8.0 because PHP APIs was changed a little.
NetBeans 8.0 tag is not available on Plugin Portal yet.

It is early to provide new nbm for NB80 because it is still beta.
But, I created a new nbm for NB80.
Please check it on github. (https://github.com/junichi11/netbeans-wordpress-plugin/releases/tag/v0.7.0)

** update **
NB80 tag is available now. But I'll add a new nbm to PP after I added some changes.

Thanks.
Posted by junichi11 on Jan 27, 2014
  

NetBeans 8.0 beta

Has anybody tested with NB8.0 beta yet?
Posted by NeilC on Jan 26, 2014
  

Perfect!

Installed 0.4.8 with no problems, thank you.
Posted by NeilC on Aug 02, 2013
  

RE: Available for 7.3.1 ?

Hi,

You are welcome!
Please try to download a new nbm from old versions / other build version in this page.
org-netbeans-modules-php-wordpress-0.4.8-for-build-201306052037.nbm
(If you can't install, please check your NetBeans build version and let me know)

Thanks.
Posted by junichi11 on Aug 02, 2013
  

Available for 7.3.1 ?

All was working just fine in 7.3, loved it! Thank You!

Just installed NB 7.3.1 and I get the following missing modules to be able to install....

plugin PHP Editor API
plugin PHP Framework API
plugin PHP Module API

Will we have to wait for a NB 7.4 verion or will this be sorted soon?
Posted by NeilC on Aug 02, 2013
  

RE: Product Version: NetBeans IDE 7.3 (Build 201302132200)

Hi praneybehl,

I have built again and uploaded a new nbm. Please try to download it.
If you can't resolve it, Please submit your problem to github issue tracker as a new issue :)
Perhaps, it is not easy for you to receive a response from me here. (You might not notice.)

Thanks,
Junichi
Posted by junichi11 on Jul 20, 2013
  

RE: Product Version: NetBeans IDE 7.3 (Build 201302132200)

Hi junichi11,

I am having the same problem as Jos. I tried to find #5, #11 on issue tracker but couldn't find anything. I am also new to Netbeans. Can you please suggest how to fix it?

Your help will be much appreciated.

Thanks,
Praney
Posted by praneybehl on Jul 20, 2013
  

RE: Product Version: NetBeans IDE 7.3 (Build 201302132200)

Hi Jos,

Please see #5, #11 on github issue tracker.

Then please submit a new issue if you can't resolve it.

Thanks.
Posted by junichi11 on May 18, 2013
  

Product Version: NetBeans IDE 7.3 (Build 201302132200)

G'day

I've install - Product Version: NetBeans IDE 7.3 (Build 201302132200)

I'm also getting the following error when trying to install your plugin.

Some plugins require plugin PHP Editor API to be installed.
The plugin PHP Editor API is requested in implementation version 201302132200. The following plugin is affected: PHP WordPress Blog/CMS
Some plugins require plugin PHP Framework API to be installed.
The plugin PHP Framework API is requested in implementation version 201302132200. The following plugin is affected: PHP WordPress Blog/CMS
Some plugins require plugin PHP Module API to be installed.
The plugin PHP Module API is requested in implementation version 201302132200. The following plugin is affected: PHP WordPress Blog/CMS Some plugins not installed to avoid potential installation problems.

I'm new to netbeans, am I missing a plugin(s), please let me know which ones.

Best regards

Jos
Posted by jos.dentoom on May 18, 2013
  

RE: 7.4 Support

Hi adam_felix_fps,

Sorry, I'll provide the nbm for 7.4 when NetBeans7.4 stable version is released.

I can't provide it here yet.

Thanks.
Posted by junichi11 on Apr 30, 2013
  

7.4 Support

Any chance of getting this to work on the latest nightlies e.g. 7.4? Get the following errors:

Some plugins require plugin PHP Editor API to be installed.
The plugin PHP Editor API is requested in implementation version 201302132200. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin PHP Framework API to be installed.
The plugin PHP Framework API is requested in implementation version 201302132200. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin PHP Module API to be installed.
The plugin PHP Module API is requested in implementation version 201302132200. The following plugin is affected:       PHP WordPress Blog/CMS Some plugins not installed to avoid potential installation problems.
Posted by adam_felix_fps on Apr 30, 2013
  

RE: Problem with installation

**this comment is repost**

Hi Bambulum,

As I write at "What's new in this version", This plugin works on only NetBeans 7.3RC1

Thus this plugin doesn't work on NetBenas7.2. I'll provide nbm with NB7.3 or later.
If you try to use this plugin, please download 7.3RC1.

Thanks.
Posted by junichi11 on Mar 25, 2013
  

Problem with installation

Hello.



First of all thanks for the plugin, but I have a problem with the installation. I click on install button (on NetBeans IDE Installer) and I receive the following message:


Some plugins require plugin Progress API to be installed.
The plugin Progress API is requested in version >= 1.32.1 but only 1.28.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Common Scripting Language API (new) to be installed.
The plugin Common Scripting Language API (new) is requested in version >= 2.33.1.2.1.1.6 but only 2.28.2.2.1.1.6 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Editor Code Completion to be installed.
The plugin Editor Code Completion is requested in version >= 1.33.1.1 but only 1.30.1.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Editor Indentation to be installed.
The plugin Editor Indentation is requested in version >= 1.31.1 but only 1.28.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Editor Library to be installed.
The plugin Editor Library is requested in version >= 3.33.2.21.40 but only 3.24.1.20.32 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin MIME Lookup API to be installed.
The plugin MIME Lookup API is requested in version >= 1.29.1 but only 1.26.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Lexer to be installed.
The plugin Lexer is requested in version >= 1.49.1.1 but only 1.46.1.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Options Dialog and SPI to be installed.
The plugin Options Dialog and SPI is requested in version >= 1.31.1 but only 1.26.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Parsing API to be installed.
The plugin Parsing API is requested in version >= 1.62.1.6 but only 1.55.1.6 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin org.netbeans.modules.php.api.editor to be installed.
The plugin org.netbeans.modules.php.api.editor is requested in implementation version 201301240957. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin org.netbeans.modules.php.api.framework to be installed.
The plugin org.netbeans.modules.php.api.framework is requested in implementation version 201301240957. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin PHP APIs to be installed.
The plugin PHP APIs is requested in implementation version 201301240957. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin PHP Project to be installed.
The plugin PHP Project is requested in implementation version 201301240957. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Project API to be installed.
The plugin Project API is requested in version >= 1.50.1 but only 1.46.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Project UI API to be installed.
The plugin Project UI API is requested in version >= 1.65.1.8 but only 1.57.1.8 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Actions APIs to be installed.
The plugin Actions APIs is requested in version >= 6.29.1 but only 6.26.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin UI Utilities API to be installed.
The plugin UI Utilities API is requested in version >= 7.55.1 but only 7.46.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Dialogs API to be installed.
The plugin Dialogs API is requested in version >= 7.28.1 but only 7.25.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin File System API to be installed.
The plugin File System API is requested in version >= 8.5.1 but only 7.62.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Datasystems API to be installed.
The plugin Datasystems API is requested in version >= 7.44.1 but only 7.37.3 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Nodes API to be installed.
The plugin Nodes API is requested in version >= 7.33.1 but only 7.28.1 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Utilities API to be installed.
The plugin Utilities API is requested in version >= 8.29.1 but only 8.25.2 was found. The following plugin is affected:       PHP WordPress Blog/CMS
Some plugins require plugin Lookup API to be installed.
The plugin Lookup API is requested in version >= 8.19.1 but only 8.15.2 was found. The following plugin is affected:       PHP WordPress Blog/CMS Some plugins not installed to avoid potential installation problems.

I'm using
- MAC OS X 10.7.5 version
- NetBeans IDE 7.2.1 (Build 201210100934)

I need Help to install this module

Thank you!!
Posted by Bambulum on Feb 10, 2013
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo