Stapler/Hudson/Jenkins Support - plugin detail

Support for Stapler and Hudson/Jenkins plugin development.

NetBeans Plugin - Stapler/Hudson/Jenkins Support
Plugin owner: jglick
Website: https://github.com/stapler/netbeans-stapler-plugin
Added: 2012-07-13
License: MIT/CDDL
Category: Editing
Downloaded: 5,912 times
Rating:
 4.4, by 1 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.10 MB   Last Update: 2017-05-19

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

1.6 Changelog plus ZIP now includes Yenta library

Verifications for NetBeans versions

8.2 verification PASSED See verification details
Download plugin   Download size: 0.10 MB   Last Update: 2017-05-19

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

1.6 Changelog plus ZIP now includes Yenta library

Verifications for NetBeans versions

8.1 verification PASSED See verification details
Download plugin   Download size: 0.10 MB   Last Update: 2017-05-19

What's new in this version

1.6 Changelog plus ZIP now includes Yenta library

Verifications for NetBeans versions

Plugin is not subject to any verification

Download plugin   Download size: 0.10 MB   Last Update: 2013-12-06

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

1.5: https://github.com/stapler/netbeans-stapler-plugin/blob/master/README.md

Verifications for NetBeans versions

7.4 verification PASSED See verification details
Download plugin   Download size: 0.10 MB   Last Update: 2013-09-22

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

See: https://github.com/stapler/netbeans-stapler-plugin/blob/master/README.md

Verifications for NetBeans versions

7.3 verification PASSED See verification details
Download plugin   Download size: 0.08 MB   Last Update: 2012-11-30

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

1.2: https://github.com/stapler/netbeans-stapler-plugin/blob/master/README.md

Verifications for NetBeans versions

7.2 verification PASSED See verification details


Introduction

Support for Stapler, used mainly by Hudson/Jenkins—currently includes a hint to refactor hardcoded strings to Messages. Also includes support for Hudson/Jenkins plugin development using Maven and Jelly.

[ You have to be logged in to be able to comment. ]

User Comments

  

Still failing in 8.2

Any resolution
Posted by vrotaru on May 05, 2017
  

NB_82 Install fails

Attempt to install in NetBeans 8.2 fails with the following:
The plugin org.netbeans.contrib.yenta.api is requested in version 1.1. The following plugin is affected: Jenkins Plugin Support
Posted by loweryr on Feb 28, 2017
  

NB 8 supported

The 7.4 binaries should work fine in 8.0, but when I get a chance I will respin binaries for 8.0. Unfortunately Plugin Portal makes this process manual and awkward.
Posted by jglick on Jun 26, 2014
  

Any plans for NB8 support?

I've been using NB8 and would rather not have to deal with another version, but will if needed.
Posted by predatorvi on Jun 18, 2014
  

Re: Dep problem with NB74 build

Thx!
Posted by ent38 on Sep 22, 2013
  

Re: Dep problem with NB74 build

Oops, yes that plugin needs to be added in too. (Was in earlier bundles but forgot it this time.)
Posted by jglick on Sep 22, 2013
  

Dep problem with NB74 build

Hi,
I can't install on NetBeans 7.4 RC1. I get this error message:
Some plugins require plugin org.netbeans.contrib.yenta.api to be installed.
The plugin org.netbeans.contrib.yenta.api is requested in version 1.1. The following plugin is affected:       Jenkins Plugin Support

Could you take a look at this? Thx!
Posted by ent38 on Sep 22, 2013
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo