Java Ayatana - plugin detail

Esta extensión permite integrar a Netbeans en el escritorio Ayatan de Ubuntu

NetBeans Plugin - Java Ayatana
Plugin owner: danjaredg
Website: http://danjared.wordpress.com/netbeans/
Added: 2012-02-08
License: MIT Licence
Category: Graphical User Interface
Downloaded: 5,779 times
Rating:
 3.95, by 9 users

Plugin Log Show log

Versions available

Download plugin   Download size: N/A   Last Update: 2012-07-24

What's new in this version

The JAyatana Plugin is supported to 7.2

Verifications for NetBeans versions

Plugin is not subject to any verification

Download plugin   Download size: N/A   Last Update: 2012-06-20

What's new in this version



Verifications for NetBeans versions

Plugin is not subject to any verification

Download plugin   Download size: N/A   Last Update: 2012-06-20

What's new in this version



Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Esta extensión permite integrar a Netbeans en el escritorio Ayatan de Ubuntu

netbeans.png

Para instalar incluye la siguiente URL: http://java-swing-ayatana.googlecode.com/files/netbeans-catalog.xml

java-ayatana-nbs-config.png?w=650

Después instala Java Ayatan

install-java-ayatana.png?w=650

[ You have to be logged in to be able to comment. ]

User Comments

  

For Ubuntu 13.10 you can install JAyatana 2

sudo add-apt-repository ppa:danjaredg/jayatana
sudo apt-get update
sudo apt-get install jayatana
Posted by danjaredg on Feb 13, 2014
  

Works on Netbeans 7.4/Ubuntu 13.10 Saucy Salamander

By starting netbeans as follow:

env UBUNTU_MENUPROXY="libappmenu.so" /path/to/netbeans [Custom netbeans startup options]

e.g. for me:

env UBUNTU_MENUPROXY="libappmenu.so" /usr/local/netbeans-7.4/bin/netbeans -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

Posted by ipernet on Nov 18, 2013
  

Problem on Ubuntu 13.10 Saucy Salamander

It isn't working on Ubuntu 13.10 32-bits.

I'm using NetBeans 7.2, and oracle jdk 1.6.

Here's the error:

java.lang.ArrayIndexOutOfBoundsException: 1
at org.java.ayatana.DesktopFile.load(DesktopFile.java:394)
at org.java.ayatana.DesktopFile.(DesktopFile.java:106)
at org.java.ayatana.DesktopFile.initialize(DesktopFile.java:63)
at org.nbs.java.ayatana.Installer.restored(Installer.java:81)
at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:469)
[catch] at org.netbeans.core.startup.NbInstaller.loadImpl(NbInstaller.java:392)
at org.netbeans.core.startup.NbInstaller.access$000(NbInstaller.java:103)
at org.netbeans.core.startup.NbInstaller$1.run(NbInstaller.java:344)
at org.openide.filesystems.FileUtil$2.run(FileUtil.java:619)
at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:127)
at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:607)
at org.openide.filesystems.FileUtil.runAtomicAction(FileUtil.java:603)
at org.openide.filesystems.FileUtil.runAtomicAction(FileUtil.java:623)
at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:341)
at org.netbeans.ModuleManager.enable(ModuleManager.java:1179)
at org.netbeans.ModuleManager.enable(ModuleManager.java:1002)
at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:296)
at org.netbeans.core.startup.Main.getModuleSystem(Main.java:169)
at org.netbeans.core.startup.Main.start(Main.java:305)
at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
at java.lang.Thread.run(Thread.java:662)

Posted by leomontenegro6 on Oct 31, 2013
  

Confirmed wont work in Ubuntu 13.10

using
jdk 1.7.0_45
Netbeans 7.4 final
Posted by marioserrano09 on Oct 20, 2013
  

Ubuntu 13.10

this plugin not work for Ubuntu 13.10
Posted by sajad_b on Oct 19, 2013
  

Working with NetBeans 7.4beta and Ubuntu 13.04

It works.
Posted by kacer on Jul 18, 2013
  

Not Working

Ubuntu 12.04, NetBeans 7.2.1, OpenJDK 1.6.0_24 - not working.
When I changed to java-7-oracle 1.7.0_09 - working.
So the problem is with OpenJDK.
Posted by vipek on Nov 08, 2012
  

This should be a part of NetBeans core

Works like magic on NetBeans 7.2 and Ubuntu 12.04
Posted by akochnev on Aug 28, 2012
  

Not working with 7.1.2 and Ubuntu 12.04

It had worked before with 7.1.1. I tried uninstalling and deactivating. But no luck. I'm using Oracle JDK 6.
Posted by rwankar on Jun 04, 2012
  

Supported Java Versions

The plugin only support:

Oracle JRE 6, Oracle JRE 7 and Open JDK 7
Posted by danjaredg on May 24, 2012
  

Does not work

NetBeans IDE: 7.1 (Build 201112071828)
Java: 1.6.0_23; OpenJDK 64-Bit Server VM 20.0-b11
System: Ubuntu Linux 11.10 2.6.38-13-generic amd64; UTF-8; ru_RU (nb)
Posted by bootch777 on May 24, 2012
  

Unity launcher lock/unlock bug

This a bug of Ubuntu, the same pass with GIMP 2.8, Wine, I'm not sure what happen, I believe, if the application class name contains special characters (gimp-2.8 %u [.-,]) or netbeas-x.x.x, I need more research
Posted by danjaredg on May 23, 2012
  

Unity launcher lock/unlock bug

Bug is repeatable by
- make sure Netbeans is not locked in Unity launcher
- Run netbeans (with Ayatana Plugins)
- on the unity launcher, right click the netbeans (choose lock/unlock)
- then bam, it is gone

Env
- OpenJDK 1.7u4
- Netbeans 7.1.2
- Ubuntu 12.04 (64bit)

Posted by kiyut on May 21, 2012
  

Worked only once

you need restar your session
Posted by danjaredg on May 17, 2012
  

Worked only once

When I installed it, it worked.
Then I checked "Lock to Launcher", closed NetBeans, launched it again form Unity launcher and it stopped working.

I reinstalled the plugin and restarted NetBeans several times and I still cant get the icon on launcher.

Got OpenJDK 7
Posted by dagguh on May 17, 2012
  

Fixed

Thanks, now it works
Posted by RiaD on May 13, 2012
  

Use OpenJDK 7

For use this plugin with OpenJDK you must use OpenJDK 7 (not work with OpenJDK 6)
Posted by JuanLuisPaz on May 13, 2012
  

Check your UPDATES

Version 1.2.0 released, this version solves problems with Java 7, and now support OpenJDK 7
Posted by danjaredg on May 12, 2012
  

danjaredg

Not works for me with Ubuntu12.04, unity, java7(openjdk)
Posted by RiaD on May 12, 2012
  

Thats all!!

What Java version do you have?
Posted by danjaredg on May 07, 2012
  

Now what?

I installed that in nb7.1 on ubuntu 12.04 and I restarted nb... and now what? How to make this work?

Because that I gave 1 star. I dont know why this page is showing 4 stars in 1 vote! Should it be a bad practice on this site? I dont know.
Posted by sidtj on May 07, 2012
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo