PHP Symfony2 Framework - plugin detail

Basic support for PHP Symfony2 Framework

NetBeans Plugin - PHP Symfony2 Framework
Plugin owner: tmysik
Website:
Added: 2011-11-04
License: CDDL-GPL-2-CP
Category: Web Applications
Downloaded: 19,660 times
Rating:
 4.23, by 7 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.03 MB   Last Update: 2011-12-19

This plugin is also available on the NetBeans Plugin Portal Update Center. Use 'Tools > Plugins' action from the NetBeans IDE main menu for convenient installation of this plugin


What's new in this version

  • Run Command
  • Create new project
  • Editing TWIG files using Smarty support


Verifications for NetBeans versions

7.1 verification PASSED See verification details


Introduction

Basic support for PHP Symfony2 Framework.

Currently, TWIG support is missing. As a work around, Smarty support is used for editing TWIG files (if TWIG files are not already registered in the IDE).

UPDATE: This plugin, together with Twig support, is part of NetBeans 7.2.

[ You have to be logged in to be able to comment. ]

User Comments

  

RE: Incompatability Issues

I have submitted issue [1] and will look at it. The fix will be available in NetBeans 7.2 and I can try to backport it to this plugin.

Thanks.
[1] https://netbeans.org/bugzilla/show_bug.cgi?id=209721
Posted by tmysik on Mar 19, 2012
  

Incompatability Issues

I have been enjoying this with Symfony 2.0.9, but have just downloaded Symfony 2.0.11 and it seems that the "Run Command" functionality is broken.

Can anyone advise?
Posted by smilinmonki666 on Mar 17, 2012
  

RE: Sources and Configuration

Hi Tomas,

yes, I will submit an enhancement, but to explain what I meant:
At the moment you can only point to a ZIP file in the Symfony2 plugin's option dialog, that contains the Symfony standard distribution. I would apprectiate if I could also point to a directory (instead a zip), that contains the distribution "unpacked".

The more I think about it, it would also be better, if I could change the used Symfony2 distribution in the project options as well, so that one can use different Versions in different projects.

The premium variant would reuse the ZIP functionality, as it would i.e. handle in some kind of a dependency management. ;-)

Sounds like a funny project.

Cheers,
Patrick
Posted by creator79 on Jan 13, 2012
  

RE: Sources and Configuration

Hi Patrick,
sources are here [1]; BTW now the Symfony2 plugin is a part of the development version of NetBeans (it will be part of NB 7.2).
Not sure what you mean by "an unpacked version of the framework" - please, submit an enhancement [2] with more details and steps to reproduce against php/Symfony.

Thanks,
Tomas
[1] http://hg.netbeans.org/web-main/file/tip/php.symfony2
[2] http://netbeans.org/community/issues.html
Posted by tmysik on Jan 09, 2012
  

Sources and Configuration

Hi,

where can I find the sources of this plugin?
And is it possible to use an unpacked version of the framework (like as I would have it when I use the Symfony2 git repository)?

Cheers
Patrick
Posted by creator79 on Jan 08, 2012
  

RE: There is allready a running Twig extension

Yes; this extension will be part of NetBeans 7.2, more information here [1].

Tomas
[1] http://blogs.oracle.com/netbeansphp/entry/initial_support_for_symfony2
Posted by tmysik on Jan 02, 2012
  

There is allready a running Twig extension

Hello tmysik

There is allready a running Twig Extension out there, i wouldnt spend to much time in supporting it in the symfony2 extension.

http://plugins.netbeans.org/plugin/37069/php-twig

Greets Dominik
Posted by dominik.zogg on Dec 28, 2011
  

RE: Some plugins require plugin Options Dialog and SPI to be installed.

One needs to use the development version of NetBeans [1] or wait for NB 7.1 RC.

Thanks.
[1] http://bits.netbeans.org/download/trunk/nightly/latest/
Posted by tmysik on Nov 16, 2011
  

Some plugins require plugin Options Dialog and SPI to be installed.

The plugin Options Dialog and SPI is requested in version >= 1.24 but only 1.23.1 was found.

The plugin PHP APIs is requested in version >= 1.53 but only 1.51.1 was found.

The plugin Lookup API is requested in version >= 8.11 but only 8.10.1 was found.


runnning 7.1beta, dl+installed today no updates available.
so how I can install this ?
Posted by daaawooo on Nov 16, 2011
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo