NetBeans Struts2 Support - plugin detail

Support for Apache Struts2 framework

n/a
Plugin owner: rohanranade
Website: http://nbstruts2support.dev.java.net
Added: 2009-12-13
License: CDDL
Category: Web Applications
Downloaded: 62,223 times
Rating:
 4.4, by 8 users

Plugin Log Show log

Versions available

Download plugin   Download size: 3.38 MB   Last Update: 2011-04-28

What's new in this version

  • Struts2 bundled library updated to 2.1.8
  • Plugin now runs on NetBeans 6.9 and above


Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Apache Struts2 is an elegant, extensible framework for creating enterprise-ready Java web applications. The framework is designed to streamline the full development cycle, from building, to deploying, to maintaining applications over time.

Features:

  • Wizard to create an example Struts 2.x application and register the Struts 2.1.8 library files.
  • Wiizards to create a new Struts Configuration file, Results/Interceptor/Action class files.
  • Hyperlinking in Struts configuration files.
  • Code completion feature in the configuration file.

[ You have to be logged in to be able to comment. ]

User Comments

  

ognl error

I have a jsp page that uses the following to set the value of a list in a struts2 radio tag:

<s:radio name="myName" list="#{'Y':'Yes','N':'No'}" />

This shows as an error in the jsp editor; it isn't an error just a special syntax for lists. The error says that it received a ":" but expected another character, which is lists.
Is this a problem for this plugin or something in the IDE?
Thanks for your help.
Posted by wcwilson1950 on Jul 26, 2012
  

Struts 2 is working with netbeans 7.0.1

Hi guys Struts 2 pligin is working with netbeans 7.0.1... thanks....
Posted by rajaveld on Sep 24, 2011
  

Re: struts2 for nb7.0 err

Should be fixed now. Please inform me in case of other errors in repack thread. I'm not related to original plug-in developers.
Posted by maks_t34 on Aug 27, 2011
  

I am Sorry for last msg , but it is sure about ..?

when I downloaded the "struts2-plugin for nb7.0" only ,it has the problem that I have discribed . but ,then I tried it again after download another "strut2-plugin for 6.9",it done!

so ,it has a order and must use "6.9" first ,isn't it?
Posted by EarthShaking on Aug 25, 2011
  

struts2 for nb7.0 err

First, I thank you for your offer of the struts2 netbeans support plug-in, then I have a question.
When I create a new project, before the choice of "framework",I can not take the next step button, so it also cannot be used now .
I downloaded is netbeans7.0 and "Struts2 Repack teachers for 7.0" NB plugin.
is it wrong about my download plugin ?or less , or what ?Can you help me, please?
Posted by EarthShaking on Aug 25, 2011
  

Great Plugin

Wao!... This is great contribution. Thanks to the developer. Please keep me in the loop with yours and such similar updates. Thanks
Posted by topgun743 on Jul 31, 2011
  

Repack for NB 7.0

I have compiled and published the repack for NB 7.0

http://plugins.netbeans.org/plugin/39218/

The description of the change is also there. Hope that author of original plug-in will add NB 7.0 support soon.
Posted by maks_t34 on Jul 09, 2011
  

Hey Guys Problems

Hi i have install netbeans 6.8 and netbeans 7.0 i tried install the plugin with no success.

can somebody give me a hand.
Some plugins require plugin Editor Library to be installed.
The plugin Editor Library is requested in version >= 2.10.1.10.2 (release version 2) but only 3.8.1.13.9 (of release version different from 2) was found. The following plugin is affected:

Thanks a Lot.
Posted by JavIut on Jun 28, 2011
  

I did it with NB6.9.1

i uninstalled the NB7.0 and installed the NB6.9.1 so the problem was solved. Thanks for helping...
Posted by serefakyuz58 on Jun 24, 2011
  

Need support for NB 7.0

Can you add support for this plugins in NB 7.0 or design new ones?
Posted by chintan4fun on Jun 23, 2011
  

Quick fix for NB 7.0

Go to http://nbstruts2support.dev.java.net and download sources (from SVN).

Open all projects in NB 7.0

In struts-support project update "Editor library - org.netbeans.modules.editor.lib" reference to
* Major Release Version = 3
* Specification Version = [your version] (e.g. 3.8.1.13.9)

Build and package nbstruts2-suite as NBMs

Sure it will warn you about using deprecated API in the source code. But nevertheless plug-in installs and works.

Find you NBMs in ${project}/trunk/nbstruts2-suite/build/updates and enjoy.
Posted by maks_t34 on Jun 22, 2011
  

plss helppp

How can i integrate the plugin to NB7 pls help =(( i try tools-->plugins-->downloaded but it did not work :((
Posted by serefakyuz58 on Jun 16, 2011
  

NB7 Update soon?

Really love this plugin. and would like to upgrate to NB7 but this is holding me back...

Guess Netbeans released web a few days ago.. not a need for this anymore?
Posted by Drono on May 24, 2011
  

Struts2 Support

Please update the support for Netbeans7, and put please the updated Struts 2.2.1 libraries :) Thank you.
Posted by hoss on May 17, 2011
  

NB 7.0 issues

Update on NB7 issue please...
Posted by tempdomain on May 14, 2011
  

NB 7.0 issues

Yes, I am working on a fix for this.
Posted by rohanranade on Apr 25, 2011
  

Help Please

I install in NB7.0 and get this..


The plugin Editor Library is requested in version >= 2.10.1.10.2 (release version 2) but only 3.8.1.13.8 (of release version different from 2) was found. The following plugin is affected:       Struts2 Support
Posted by jorp78 on Apr 25, 2011
  

Tons of Thanks

Trying to get hold of NB. Returning back after long time to programming. Makes my life easier!
Posted by sandeep.rajarao on Nov 28, 2010
  

Great Work :)

thanks a lot it is really usefull :)
Posted by JRzayev on Oct 10, 2010
  

This is great!

Thank you for the plugin! :)
Keep the great work up!
Posted by jmhu on Sep 16, 2010
  

¡Struts está bien! ...

Thank you! It is nice to have support on Netbeans!
Posted by costis on Sep 07, 2010
  

¡Struts está bien! ...

Thank you! It is nice to have support on Netbeans!
Posted by costis on Sep 07, 2010
  

Date for next release

The next release of this plugin - compatible with NetBeans 6.9 is set for 16 August 2010.
Posted by rohanranade on Jul 22, 2010
  

Update coming soon

Yes, an update is coming. I am working on it. The following changes are planned:
1. Update Struts2 library to latest version
2. Update to work on NetBeans 6.9
Posted by rohanranade on Jun 24, 2010
  

NB 6.9

Hi Rohanranade!
Nice tool! Thank you!
Will you upgrade soon for NB6.9?
Posted by costis on Jun 18, 2010
  

NB 6.9

Hi Rohanranade!
Nice tool! Thank you!
Will you upgrade soon for NB6.9?
Posted by costis on Jun 18, 2010
  

Support for Struts 2.1.x

Hello,

I have a question, are there any plans to support 2.1.x-branch of Struts 2?
Posted by sascha_mav on Mar 23, 2010
  

Built for NB 6.7 and higher

Yes Hantsy, it is just updated to run on NB 6.7 and higher. I'm mailing you separately regarding the patches that you sent along.
Posted by rohanranade on Dec 15, 2009
  

What's new about this version?

It is just rebuilt on the newest NetBeans 6.7.1?
Posted by hantsy on Dec 15, 2009
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo