Texbeans - plugin detail

Texbeans is a latex editor mode for netbeans with compiler and view support

n/a
Plugin owner: kiar
Website: https://texbeans.dev.java.net/servlets/ProjectDocumentList
Added: 2008-10-28
License: BSD
Category:
Downloaded: 1,308 times
Rating:
 0, by 0 users

Plugin Log Show log

Versions available

Download plugin   Download size: N/A   Last Update: 2009-07-01

What's new in this version



Verifications for NetBeans versions

Plugin is not subject to any verification

Download plugin   Download size: N/A   Last Update: 2009-07-01

What's new in this version



Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Texbeans 0.2 alpha is a "stable" alpha release

current features are
- Latex editor mode (colors)
- code completion (Ctrl-Space)
- build and view support (latex, bibtex and xdvi, linux)
- code injection (Alt-Enter)
- include and input support (hyperlinks)
- navigator support (table of contents for all latex files)
- wordfetcher (thesaurus)

planned:
- bibtex support (using jabref)

[ You have to be logged in to be able to comment. ]

User Comments

  

Re: THX (Doesn't work with 6.7)

I was about to ask the question as to whether it was going to be fixed, but I see the fields have been updated to suggest it will. I look forward to it, it will be a cool plugin :).
Posted by lionelv on Jul 01, 2009
  

THX (Doesn't work with 6.7)

Because Texbeans needs the deprecated pre61completion there is no NB 6.7 support
Posted by kiar on Jul 01, 2009
  

Doesn't work with 6.7

I get an error message trying to load in 6.7:

Activation failed: Not all requested modules can be enabled: [StandardModule:net.sf.texbeans.language jarFile: C:\Documents and Settings\vandenbergl\.netbeans\6.7\modules\net-sf-texbeans-language.jar, StandardModule:net.sf.texbeans.nativesupport jarFile: C:\Documents and Settings\vandenbergl\.netbeans\6.7\modules\net-sf-texbeans-nativesupport.jar, StandardModule:net.sf.texbeans.hints jarFile: C:\Documents and Settings\vandenbergl\.netbeans\6.7\modules\net-sf-texbeans-hints.jar, StandardModule:net.sf.texbeans.api jarFile: C:\Documents and Settings\vandenbergl\.netbeans\6.7\modules\net-sf-texbeans-api.jar, StandardModule:net.sf.texbeans.project jarFile: C:\Documents and Settings\vandenbergl\.netbeans\6.7\modules\net-sf-texbeans-project.jar]

During start up it says:

The module named org.netbeans.modules.editor.deprecated.pre61completion/0 was needed and not found.
Posted by lionelv on Jul 01, 2009
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo