NetBeans 6.1 Plugin for Struts 2.x Framework - plugin detail

Apache Struts 2 is an elegant, extensible framework for creating enterprise-ready Java web applications. The framework is designed to streamline the full development cycle, from building, to deploying, to maintaining applications over time. As a part of supporting development of a Web Application using Struts 2.x framework in NetBeans 6.1, we have developed this plugin. The features implemented in this first cut out are : * Wizard to create an example Struts 2.x application and register the Struts 2.0.11 library files. * Wiizards to create a new Struts Configuration file, Results/Interceptor/Action class files. * Hyperlinking in Struts configuration files. * Code completion feature in the configuration file. Note: This plugin is for NetBeans 6.0 and 6.1 only. If you are running NetBeans 6.7 or higher, please visit - http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=23467

NetBeans Plugin - NetBeans 6.1 Plugin for Struts 2.x Framework
Plugin owner: rohanranade
Website: http://nbstruts2support.dev.java.net
Added: 2008-06-27
License: CDDL
Category: Web Applications
Downloaded: 30,334 times
Rating:
 4.18, by 2 users

Plugin Log Show log

Versions available

Download plugin   Download size: N/A   Last Update: 2011-04-28

What's new in this version

Note: This version is not supported anymore. Please use the latest version at http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=23467 NetBeans 6.1 support for Struts 2.x Contains a Struts 2.0.11 library wrapper module and NetBeans plugin for supporting Struts Framework. Need to install both the plugins

Verifications for NetBeans versions

6.1 verification FAILED See verification details
Download plugin   Download size: N/A   Last Update: 2011-04-28

What's new in this version

Note: This version is not supported anymore. Please use the latest version at http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=23467 NetBeans 6.1 support for Struts 2.x Contains a Struts 2.0.11 library wrapper module and NetBeans plugin for supporting Struts Framework. Need to install both the plugins

Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Detailed description at http://nbstruts2support.dev.java.net

[ You have to be logged in to be able to comment. ]

User Comments

  

Version for NB 6.7.1 available

Please use the latest version for NetBeans 6.7 or higher from http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=23467
Posted by rohanranade on Dec 13, 2009
  

I provide an unofficial update.

http://hantsy.blogspot.com
Posted by hantsy on Aug 27, 2009
  

My previous Comment was about Struts2, not Struts1

Thanks jkovalsky for your reply. Actually my ques was of Struts2 support, not Struts1.. Struts1 plugin is already there with Netbeans...But Struts2 plugin doesnt work with Netbeans 6.7... I am a big fan of Netbeans atleast after downloading and looking at how easily features are integrated/available but cant start any development as basic Stuts2 framework is not there... I need to do integration and all development manually, i dont need an IDE for that. I really wish Struts2 support will come to 6.7 soon..
Posted by pruthik_21 on Aug 16, 2009
  

Good news

Thanks for your comment Kapil! Why don't you use NetBeans 6.7 and download Struts integration from the NetBeans Update Center? Besides, more enhancements in Struts support are planned for NetBeans 6.8.
Have a nice day!
Posted by jkovalsky on Aug 10, 2009
  

Disappointing

I am already moving to different IDE... Struts2 should be basic, i wonder how come this advanced IDE doesnt have the basic framework which is used by almost every J2ee developer
Posted by pruthik_21 on Aug 09, 2009
  

netbeans 6.7.1 with struts 1.3.8

I have already downloaded the latest netbeans verision (6.7.1) and still offering struts version 1.3.8.
How can I install struts 2.0 in netbeans 6.7.1?

Thanks in advance
Posted by wgualla on Aug 06, 2009
  

Error with Netbeans 6.7

Hello
This plugin can't install on netbeans 6.7. Where can find new version of this?
And
Why netbeans 6.7 integrate Struts 1.x not Struts 2.x ?
Thank you
Posted by mohsenetc on Jul 11, 2009
  

NetBeans 6.7.1

Yes, we plan to release Update 1 for NetBeans 6.7 by the end of July. For more information see: http://wiki.netbeans.org/NetBeans671
Posted by jkovalsky on Jul 09, 2009
  

Is it abbandonated?

there will be a new release for NetBeans 6.7?
Posted by superman1001 on Jul 09, 2009
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo