Spring Netbeans Module - plugin detail

Provides support for the Spring Framework in older versions of the Netbeans IDE (5.5,6.0). The Spring Framework plugins are now integrated within the Netbeans IDE since version 6.1 and no additional plugins are required. Also, please post comments about the integrated Spring Framework support to the nbusers@netbeans.org mailing lists, and submit issues using the tracking system at http://www.netbeans.org.

NetBeans Plugin - Spring Netbeans Module
Plugin owner: craigmackay
Website: http://spring-netbeans.sourceforge.net/
Added: 2007-04-03
License: Apache License V2.0
Category:
Downloaded: 28,938 times
Rating:
 4.03, by 3 users

Plugin Log Show log

Versions available

Download plugin   Download size: N/A   Last Update: 2008-12-09

What's new in this version



Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

The module provides the ability to select the Spring Framework when creating web applications in older versions of the Netbeans IDE(5.5,6.0). The module also adds third party libraries, configures the web.xml, and registers an XML catalog which provides code completion in Spring configuration files.

[ You have to be logged in to be able to comment. ]

User Comments

  

Problem When Installing This Plugin

Hello, I'm Ruli from Indonesia.
I've try to install this plugin in my NetBeans IDE 6.0.1, but there's appear message that contain the following text: "Cannot read NBM 1196642071301_spring-support-plugin-1.1.nbm because error in opening zip file". I've already has a zip file of Spring Framework. How was that happen (appear error message)? How the way to install that plugin in NetBeans so that I could use Spring Framework as a choice when I create a web application? Plese, help me...
Thank's before for yours help. Sorry if my English not good.
Bye...
Ruli
Posted by ruli on Jul 05, 2008
  

How to give my feedback?

Hi there,

you should update the feedback link to the netbeans site here:
http://spring-netbeans.sourceforge.net/?page_id=5
because there is no such a tracker on sourceforge ...

My 2 questions:
Is it possible to refactor a class and the plugin will make the changes to the xml?
Do you looked into geertjans nice work here (for the SpringRC):
http://java.dzone.com/news/spring-rcp-tutorial

Regards.
Posted by peathal on Jul 03, 2008
  

Very Nice

I've used Eclipse/SpringIDE and didn't like the fact that it couldn't even attached the basic Spring jar files to a project nor could it add folders and modify the web.xml or automatically create a servlet. And when I asked in the forums if they planned on doing this since Netbeans could, I was told to use Netbeans. So here I am using Netbeans :D

Great Job!!! Keep up the good work.
Posted by cmattmiller on May 29, 2008
  

Good work,...

... I really enjoy where this plugin is heading. It's not yet next to SpringIDE / Eclipse, but it's a good thing to start with on NetBeans. :)
Posted by kawazu428 on Jan 14, 2008
  

Support requests

All plugin support requests must be submitted using the sourceforge bug tracker including all relevant details (specific version of IDE, environment, when the problem occurs, etc).

http://sourceforge.net/tracker/?group_id=174340&atid=868844
Posted by craigmackay on Jan 08, 2008
  

Re:Spring Netbeans plugin error

Hi
I have the same error, already you know how load the Spring Framework correctly.
Please answer me.
Posted by jgomezc on Jan 07, 2008
  

Spring Netbeans plugin error

I tried to install Spring Netbeans plugin on netbeans 6.0 but got the following error:

Plugin Spring Framework Support cannot match its dependencies:
module org.netbeans.api.java/1 > 1.13.1 module org.netbeans.libs.javacapi > 0.5.1.1 module org.netbeans.modules.editor.lib/1 > 1.20.1.4.2 module org.netbeans.modules.editor/3 > 1.35.1.4.2 module org.netbeans.modules.java.source > 0.26.1.1.5 module org.netbeans.modules.projectuiapi/1 > 1.24.1.6 module org.openide.awt > 6.11.1.1 module org.openide.loaders > 6.7.1 module org.openide.nodes > 7.2.1.1 module org.openide.text > 6.16.1 module org.openide.windows > 6.18.1
Posted by msincuba on Dec 18, 2007
  

Netbeans 6 support

There is an updated version of the module on the sourceforge site that supports 6.0. It does not work on 5.x, so I have not updated the plugin portal download. As soon as the Netbeans 6.0 version is officially released I will update the version that is available on the plugin portal. Until then it can be downloaded from the sourceforge site at:

Sourceforge Dowload
Posted by craigmackay on Sep 05, 2007
  

NetBeans 6 support

What will it take to make this compatible with NetBeans 6? It is a useful plugin.
Posted by kurtrisser on May 31, 2007
  

This is good framwork

This framework can do everything without doing any thing.
Posted by vivek_patel49 on May 23, 2007
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo