Google Translator Integrator - plugin detail

Client for Google translation service integrated into NetBeans IDE. Interacts with Google translation service on-line, hence you need to be on-line. By default, the setting is English/French. Supported languages: Arabic, Chinese, Dutch, English, French, German, Italian, Japanese, Portuguese, Russian, Spanish.

NetBeans Plugin - Google Translator Integrator
Plugin owner: geertjan
Website: http://www.javalobby.org/java/forums/t103431.html
Added: 2007-11-24
License: CDDL
Category: NetBeans Rich Client Platform
Downloaded: 1,902 times
Rating:
 4.21, by 1 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.01 MB   Last Update: 2012-04-11

What's new in this version

Incremented to 1.5. Now all file types are supported, not just HTML and Java. Now the lists are in their own new toolbar, called Translate, instead of in the Edit toolbar. Added "to" between the two lists. Added display text for the Plugin Manager.

Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Instructions:

  1. Install the two modules.
  2. Look in the Translate toolbar (View > Toolbars > Translate, if it is closed) where you should see two lists of languages.
  3. Choose two languages, first is "from", second is "to".
  4. Open any kind of file.
  5. Select text.
  6. Right-click and choose Translate.
  7. Text changes from "from" language to "to" language.
  8. If a problem occurs, message is printed in status bar. For example, Google translation service doesn't support all from/to combinations.

Summary:

1195900666618_google-translate1.png

[ You have to be logged in to be able to comment. ]

User Comments

  

re: Unicode is not working in my IDE Editor

Thanks Mr. Geertjan for your support, i believe too it may be a problem in the RC2 release.
Posted by waelaziz74 on Nov 30, 2007
  

re: Unicode is not working in my IDE Editor

I've looked at it some more. Sometimes the Arabic text looks a bit faded, somehow. I don't know why this is the case. I can't reproduce this consistently. If you continue getting this problem, please file an issue in Issuezilla. Thanks!
Posted by geertjan on Nov 29, 2007
  

re: Unicode is not working in my IDE Editor

I'm not sure why you are copying and pasting. You're supposed to select some text. Then right-click and choose Translate. The from/to languages determine from which to which language the text will be translated. Copying and pasting has nothing to do with this module.
Posted by geertjan on Nov 28, 2007
  

re: Unicode is not working in my IDE Editor

Still not working for me, I'm using the Netbeans 6.0 RC2, but when i copy and paste Arabic sentence it show up fuzzy when i hover the mouse over it and even can't translate it back to English, is there a way i can choose a font for the editor, may be it will solve it.
Posted by waelaziz74 on Nov 28, 2007
  

re: Unicode is not working in my IDE Editor

Strange. It should be working. It works for me, no problem, look here for an example that shows Arabic:

http://www.javalobby.org/java/forums/t103431.html
Posted by geertjan on Nov 26, 2007
  

Unicode is not working in my IDE Editor

this is a very great addition to netbeans, many thanks.
my IDE is not showing Arabic translations, any workaround solution.
Posted by waelaziz74 on Nov 26, 2007
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo