Line Tools - plugin detail

NB 6.0 compatible version of the 5.X compatible LineTools module on my blog ( http://blogs.sun.com/roller/resources/scblog/update-center.xml ).

NetBeans Plugin - Line Tools
Plugin owner: sandipchitale
Website: http://blogs.sun.com/scblog
Added: 2007-10-17
License: CDDL
Category: Editing
Downloaded: 1,129 times
Rating:
 4.32, by 2 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.05 MB   Last Update: 2009-08-08

What's new in this version

Remove unused dependencies.

Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

Actually this is an NB 6.0 compatible version of the 5.X compatible LineTools module on my blog ( http://blogs.sun.com/roller/resources/scblog/update-center.xml ).
Now that the Move/Copy Selection/Line Up Down actions have become part of the standard NetBeans editor I have removed them from this module. Thus this module now only contains the other actions described in these blog entries:
  • http://blogs.sun.com/scblog/entry/updated_linetools_module_added_cycle
  • http://blogs.sun.com/scblog/entry/updated_linetools_module_added_ability
  • http://blogs.sun.com/scblog/entry/updated_linetools_module
  • http://blogs.sun.com/scblog/entry/updated_linetools_module_added_exchange
web tracker

[ You have to be logged in to be able to comment. ]

User Comments

  

Plugin for 7.x

The plugin was repackaged for NB 7.x - see http://plugins.netbeans.org/plugin/45925/?show=true
Now you can sort and filter within your editor.
Posted by markiewb on Jan 07, 2013
  

Sources

FYI: sources available at http://hg.netbeans.org/main/contrib/file/af4aac727a19/linetools/
Is somebody there, who want's to fork it and make it compatible to 7.x?!
Posted by markiewb on Jan 07, 2013
  

Incompatible with 6.9.1

Not all of it, sorting lines isn't for example!
Posted by mirceade on Jul 26, 2012
  

Incompatible with 6.9.1

Hi kAlvaro,

The functionality of this plugin is part of standard NetBeans since 6.5.
Posted by sandipchitale on Nov 10, 2010
  

Incompatible with 6.9.1

It's not compatible with Netbeans 6.9.1 (the installer complains about dependencies)
Posted by kAlvaro on Nov 10, 2010
  

RE: Doesn't install under 6.x+

Hi entonio,

Try the latest version 1.18 and let me know if you have any problems installing it.
Posted by sandipchitale on Aug 08, 2009
  

RE: Doesn't install under 6.x+

I will look into it.
Posted by sandipchitale on Aug 08, 2009
  

Doesn't install under 6.x+

Hi. This plug-in seems to be great but doesn't seem to install under the latest daily builds. Could it be something easy to solve? Thank you!
Posted by entonio on Jul 22, 2009
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo