BPEL template based Document Generator (NB 6.5) - plugin detail

OpenOffice Template based documentation generation for BPEL 2.0 files. This provides additional feature not available in the standard BPEL documentation option.

n/a
Plugin owner: dante
Website: http://blogs.sun.com/toxophily/entry/open_esb_tip_netbeans_plugin
Added: 2009-08-04
License: CDDL
Category: Documentation
Downloaded: 1,604 times
Rating:
 0, by 0 users

Plugin Log Show log

Versions available

Download plugin   Download size: 8.32 MB   Last Update: 2011-05-03

What's new in this version

Signed and added additional upload function to allow user to specify the destination Spaces Registry 1) Modified to link to the JAXB 2.1 / Xerces Modules to resolve some issues that were causes NetModule development not to correctly display Action Options. 2) Add first cut of Artifact Upload functionality. 3) Created NetBeans 6.7.1 build but this will exist as a separate plug-in because of the incopatibilities with the JAXB 2.1 Module

Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

The current implementation of Open ESB provides the developer with the ability to generate pdf based reports for their BPEL processes. By its nature this functionality is restricted in what it can provided and often does not meet the projects requirements simply taking the documentation added to the the various BPEL activities and writing it out to a pdf whilst also generating a graphical representation of the BPEL that frequently does not fit into the document correctly.

[ You have to be logged in to be able to comment. ]

User Comments

  

NB 6.7.1 Support

I have rebuilt the Module under NB 6.7.1 and uploaded it to http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=21794
Posted by dante on Oct 15, 2009
  

NB 6.7 & 6.1 Support

I do intend modifying this so that it is supported for NB 6.1 (for Java CAPS 6.0 users) and 6.7. I just the spare cycles.
Posted by dante on Sep 16, 2009
  

NB6.7.1 support?

Sounds very useful, are you planning the NB 6.7.1 and later support soon? - This plugin suite failed to install on 6.7.1 with all ESB components with the following error message: "Some plugins require plugin JAXB 2.1 Library to be installed.
The plugin JAXB 2.1 Library is requested in implementation version 090515. The following plugin is affected:       BPEL 2.0 Documentation Generator Core Library" even though the JAXB2.1 is indeed installed.
Posted by asmotrich on Sep 02, 2009
  

NB6.7.1 support?

Sounds very useful, are you planning the NB 6.7.1 and later support soon? - This plugin suite failed to install on 6.7.1 with all ESB components with the following error message: "Some plugins require plugin JAXB 2.1 Library to be installed.
The plugin JAXB 2.1 Library is requested in implementation version 090515. The following plugin is affected:       BPEL 2.0 Documentation Generator Core Library" even though the JAXB2.1 is indeed installed.
Posted by asmotrich on Sep 02, 2009
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo