ZK Designer plugins for netbeans 6.1 - plugin detail

ZK Designer is a plugins for netbeans to make the development of zk ajax framework more fast it contains all the library and most of the ZK components

NetBeans Plugin - ZK Designer plugins for netbeans 6.1
Plugin owner: ayman_gh
Website: http://elgharabawy.hostrator.com/NetBeansDemos/NetBeansZK.html
Added: 2008-10-11
License: GNU
Category:
Downloaded: 6,842 times
Rating:
 3.55, by 3 users

Plugin Log Show log

Versions available

Download plugin   Download size: N/A   Last Update: 2008-10-16

What's new in this version



Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

ZK designer is a plugins to help the developer to develope fast with zk it contains all the zk lib 3.5.1 that needs to develope the zk applications and it configured the web.xml so it just create zul file and deploy it works. you can download the plugins directly from my site http://elgharabawy.hostrator.com/NetBeansDemos/files/ZKPluginsnb6.1.zip

[ You have to be logged in to be able to comment. ]

User Comments

  

NB6.1 PATCH 4 Missing required Modules

Missing required modules for Plugin REM:
XML Tools API [module org.netbeans.api.xml/1 = 200809100101]
Java Project Support [module org.netbeans.modules.java.project/1 = 200809100101]
External Libraries [module org.netbeans.modules.project.libraries/1 = 200809100101]
Project API [module org.netbeans.modules.projectapi/1 = 200809100101]
Common Palette [module org.netbeans.spi.palette/1 = 200809100101]
Dialogs API [module org.openide.dialogs = 200809100101]
File System API [module org.openide.filesystems = 200809100101]
Datasystems API [module org.openide.loaders = 200809100101]
Nodes API [module org.openide.nodes = 200809100101]
Text API [module org.openide.text = 200809100101]
Window System API [module org.openide.windows = 200809100101]




Solutions?
Posted by agharta on Oct 20, 2008
  

JavaScript

After installing the update plugins for NB 6.1 the install is OK now.
I noticed though that the JavaScript interpreter was not working (installed) when referring to by zscript language.
Posted by guyvo on Oct 19, 2008
  

missing plugins

Same here:

Missing required modules for Plugin Database Explorer:
... a lot more

Can you please provide a list of needed plugins here
Posted by guyvo on Oct 19, 2008
  

Netbeans IDE installer can't install the all plugins

I can't install the 4 plug in for zk . Following messages appear :
- Missing required modules for Plugin Database Explorer
- Missing required modules for Plugin Editor Library
- Missing required modules for plugin Explorer & Property Sheet API
- Missing required modules for Plugin Java EE server Registry
- Missing required modules for Plugin Nodes API

AnyOne can say if I need extra additional plug in ?
Posted by mrakotoson on Oct 17, 2008
  

Download link broken!!

Hi its appear that download link is broken, ayman_gh can you upload the plugin directly to Netbeans Plugin Portal??

Thanks
Posted by marioko on Oct 16, 2008
  

All ok, but....

All right, but Netbeans find a new version of RichFacesLibrary(1.0 > 1.3) and RichFacesPalette (1.2 > 1.3) in the http://plugins.netbeans.org/nbpluginportal/files/nbms/pluginportal-update-center.xml

If i upgrade, the Palette becomes unavailables.

RichFaces 1.3 upgrade?

Another question? Code completion??

Bye
Posted by agharta on Oct 13, 2008
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo