nbscala-2.8.x - plugin detail

Full featured Scala IDE based on NetBeans.

n/a
Plugin owner: dcaoyuan
Website: http://wiki.netbeans.org/Scala
Added: 2008-08-05
License: CDDL/GPL
Category: Programming Languages
Downloaded: 5,243 times
Rating:
 4.37, by 9 users

Plugin Log Show log

Versions available

Download plugin   Download size: 23.98 MB   Last Update: 2011-05-21

What's new in this version



Verifications for NetBeans versions

Plugin is not subject to any verification



Introduction

An integrated development environment for building, running, testing, and debugging Scala applications.

Features:

  • Full featured editor providing syntax and semantic coloring, source file navigator, code folding, mark occurrences, go to declaration, instant rename, indentation, formating, pair matching, error annotations, code completion
  • Junit integration
  • Maven integration
  • Project management
  • Debugger
  • Interactive console

[ You have to be logged in to be able to comment. ]

User Comments

  

not working with Netbeans 6.7.1

Howdy,
the "download" button here gets you an old version of the plugin which is incompatible with the current netbeans download 6.7.1. Dunno why the download button exists then :P...

Get the latest version here instead: http://wiki.netbeans.org/Scala#section-Scala-1.GetStartedWithNetBeans6.7

Enjoy! ;)
Posted by schipplock on Sep 22, 2009
  

look at this error

Could not load definitions from resource scala/tools/ant/antlib.xml. It could not be found.
init:
deps-jar:
C:\Documents and Settings\Administrador\Mis documentos\NetBeansProjects\ScalaApplication9\nbproject\build-impl.xml:405: The following error occurred while executing this line:
C:\Documents and Settings\Administrador\Mis documentos\NetBeansProjects\ScalaApplication9\nbproject\build-impl.xml:229: Problem: failed to create task or type fsc
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any / declarations have taken place.
BUILD FAILED (total time: 0 seconds)
Posted by kal45 on Sep 15, 2009
  

Please use new plugin at sourceforge.net

@patricktinkham, please use new plugin at:
http://sourceforge.net/project/downloading.php?group_id=192439&filename=scala-plugin-090118.zip&a=27956693
Posted by dcaoyuan on May 25, 2009
  

question

I downloaded the plugin and added it per the instructions. I restarted NetBeans and attempted to create a new scala project, yet scala did not appear in the wizard. I rebooted and tried again, but with the same result. Suggestions? Thanks.
Posted by patricktinkham on May 24, 2009
  

question

I downloaded the plugin and added it per the instructions. I restarted NetBeans and attempted to create a new scala project, yet scala did not appear in the wizard. I rebooted and tried again, but with the same result. Suggestions? Thanks.
Posted by patricktinkham on May 24, 2009
  

Fully Working on 6.5

Just for the record it works now on the official 6.5 release. Thanks Caouyuan for this excellent work allowing us to work on Scala with our favourite IDE. Check the sourceforge project for the updated version.
Posted by tomygun on Nov 25, 2008
  

For 6.5RC users

I packed a new Scala plugin, and tried several times to upload it to NetBeans' Plugins Portal and could not get job successfully done. So I uploaded it to sourceforge.net instead. For more information, please visit:
http://blogtrader.net/page/dcaoyuan/entry/new_scala_plugin_for_netbeans
Posted by dcaoyuan on Nov 07, 2008
  

Re: Can't Use Pluggin on 6.5 RC1

use the nightly build, see "Adventure with NetBeans Nightly Build"
on page http://wiki.netbeans.org/Scala
Posted by dft on Nov 06, 2008
  

Can't Use Pluggin on 6.5 RC1

I've successfully added the plugin on Beta but I get this on RC1:

Some plugins require plugin Common Scripting Language API to be installed.
The plugin Common Scripting Language API is requested in version >= 1.5 but only 1.8.1.1.6 was found. The following plugins are affected:       Scala Debugger Projects Integration       Scala Editing       Scala Project
Some plugins require plugin Java Source to be installed.
The plugin Java Source is requested in implementation version 5. The following plugin is affected:       Scala Editing

The plugins that can't be added are:
Scala Project
Scala Kit
Scala Debugger Projects Integration
Scala Editing
Scala Debugger

Is there a workaround? The part that bothers me is: "The plugin Common Scripting Language API is requested in version >= 1.5 but only 1.8.1.1.6 was found" isn't 1.8 >= 1.5 ???

Thanks in advance
Posted by tomygun on Oct 29, 2008
  

Currently the best plugin for scala.

This kicks the pants off the eclipse plugin :)

For serious Scala work, its all good.
Posted by blair on Aug 31, 2008
  

Great plugin!

Every NetBeans user interested in Scala should grab this plugin. It is very significantly more useful than a plain-text editor for Scala, and it has shown amazing progress over the last few months. I personally can't wait to see this included in the main distribution.
Posted by lancelet on Aug 25, 2008
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo