Tools and Mobility support for Project Darkstar - plugin detail

This plugin provides J2ME client APIs for Project Darkstar (implemented as both HTTP and sockets), as well as Darkstar server management tools.

NetBeans Plugin - Tools and Mobility support for Project Darkstar
Plugin owner: kherink
Website: https://darkstarmobile.dev.java.net/
Added: 2008-08-04
License: CDDL
Category:
Downloaded: 2,134 times
Rating:
 0, by 0 users

Plugin Log Show log

Versions available

Download plugin   Download size: 0.51 MB   Last Update: 2009-01-06

What's new in this version

Support for Project Darkstar 0.97

Verifications for NetBeans versions

6.5 verification PENDING See verification details


Introduction

Project Darkstar has great potential to revolutionize massively multi-player online game development but severely lacks tools support. Basic tasks such as starting/stopping instances of server applications must be currently performed using command line. This NetBeans plugin integrates common server oprations (start/stop/configure) into natural workflow within the IDE. While there is no question that most games based on the Java platform are targeted for J2ME enabled devices, project PDS doesn't offer any tools (or even API level support) to mobile developers. NetBeans on the other hand, already is one of the best Mobile Java tools available. This plugin provides the missing Mobile client APIs for Project Darkstar (implemented using HTTP and sockets) packaged in the form of sample projects and mobile code snippets.

[ You have to be logged in to be able to comment. ]

User Comments

  

Update

Please update. I'm just use this plugin, but server v0.10.2.1. When login from Client, server say "SEVERE: got protocol version:4, expected 5"
:(
Posted by xuannt88 on Apr 24, 2011
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo